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Banner Foundations Overview 
 

Overview 
A. Accessing Banner: 

Accessing Banner from on-campus 

• Open a new browser and go to http://my.fairfield.edu. Login using your NetID and 
password. 

 
 
 
 
 
 
 
 
 
 
 
 
 

• From the Employee Tab, select Banner Tools to see the following screen. Choose the “Banner Main 
Menu” link. Or, you may click on the “B” icon in the QuickLaunch Navigation. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

• You will ONLY see the following screen the first time you access Banner from my.Fairfield.edu, or if you 
change your Banner password.  (Please note that your Banner username may be different than your 
NetID).   

 

 

 
 
 
 
 
 
 
 

Accessing Banner from off-campus 
In order to access Banner from off-campus, you will need to use VPN to connect to our 
network first.  If you are interested in this option, please contact Help Desk for the latest 
instructions on using VPN.  Once you are connected to the Fairfield University network via 
VPN, you may login to Banner via the my.Fairfield portal per the above steps. 

http://my.fairfield.edu/
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B. About Banner  
Banner is the University’s single System of Record, housing student, staff, alumni, and financial records 
in a unified, secure environment.   Banner is a vast, relational database where data is stored in different 
modules (student, alumni/advancement, finance, financial aid, human resources). Since the database is 
relational, this means that data can be accessed across modules.  Banner is a Student Information 
System, “SIS”, and also and Enterprise Resource Planning System, “ERP”.  Banner information can be 
entered or viewed in two ways: 

 
• Banner Self Service:  Banner Self Service enables access to certain commonly-used Banner 

information via a streamlined web interface.  Banner Self Service is available via the “Self Service 
Links”  tab in my.Fairfield.edu as shown below: 
 

 

  
 

.  
   Explore the Banner Self Service map below to familiarize yourself with this layout and functionality 
 

 

Banner Self Service offers personalized information by displaying 
horizontal tabs of categories to which each user is uniquely 
permissioned in the Banner system. The active tab appears dark 
blue, and the other available tabs appear gray. There is also a 
Search box, where a keyword can be entered to display categories 
associated with key words. Note: spelling must be correct 
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• Banner forms:  The Banner system is built on a series of ‘forms’ that display data for inquiry, 
modification or reporting.  Banner forms are also available via the my.Fairfield.edu portal, as shown 
below: 

 

 
 
 

 
Explore the Banner Main Menu as seen when Banner is accessed via Banner Forms: 
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C. Navigating Banner:  The Banner system utilizes a Menu Bar, a Tool Bar with icons, and keyboard 
function keys for navigation.  All three of these navigational options provide the same functionality, but 

offer choice to users based on preference.  Explore the three methods of navigating Banner below: 

 

• Menu Bar (File-Edit-Options-Block-Item-Record-Query-Tools-Help) 

 

 

File-Contains standard Banner functions  *includes Preferences 
Edit-Contains standard Edit functions (cut, copy, paste) 
Options-varies from form to form. Same as right-clicking on a blank section of a form. 
Block-moves from one block to another 
Record-moves from one record to another 
Query-used to search the database based on specific criteria 
Tools-used to access BDMS (scanning, etc) and Workflow 
Help-accesses help, as explained below 

 
 

When using the Menu Bar, you may also combine the ALT key with the first letter of the menu item 
to launch the command: 

 
 
 

 

• Tool Bar- The Tool Bar offers iconic versions of the same commands provided by the Menu Bar.  

Hovering the cursor over an icon will display Bubble help, which is a description of the icon   
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• Function keys (keyboard combinations that provide commands to Banner)  
 

 

 

 
  

Go To 
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D. Banner Modules:   
 

There are literally hundreds of different Banner forms, each uniquely named according to a naming 
structure, and each permissioned specifically based on job function or role within the University.  See 
the table below which outlines how the first letter of the form name applies to different University 
areas: 
 

 
Name begins with Module Information contained in Module 

A Advancement Gifts, promised commitments, activities 
E BDMS Scanning Used for online document storage/retrieval 
F Finance Budgets, chart of accounts, purchasing 
T Accounts Receivable Student billing, tuition, fees, charges payments 
G General to all People, demographic data, vendors, menus 

P or N Payroll / Human Resources / Budget Salaries, checks/benefits, positions, job history 
R Financial Aid Calculates awards, places credits on student 

accounts 
S Student Courses, enrollments, terms, grades, applications, 

student profile 
 
NOTE:  See Appendix A for further details on naming conventions 
 

 
 

E. Banner Instances:   At Fairfield University, we have three different instances of Banner as follows: 

• Banner Production – used for “live” real-time data and for most daily work 
• Banner ProdCopy – used for testing and some reporting. This is a copy of yesterday’s data 
• Banner PreProd-used for testing and development of new applications. 
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F. Accessing information via Banner forms:  There are six ways to access Banner forms as 
follows: 

 
 

• Hierarchical menu from Banner Main Menu (expand or close folders of forms). The Banner 
Main Menu displays a folder structure, where each folder contains the forms available to the user who is 
logged in. Each folder can be expanded or closed by clicking the folder to toggle. 

 

  
 
 

• “Go To” field from Main Menu  use arrow keys to display previously opened forms, or enter 
the name of the form directly into the Go To box and press enter 

 

 
 
 

•  “Go To” by using the F5 keyboard hotkey to display the “Go To” field from another form 
  

TIP:  Notice that FOLDERS of forms 
are annotated with a star *. Forms 
do not have a star notation 
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• “Options” Menu key to show forms that are available from within a form.  This will show forms 
that are related to the current Banner form. 
 

 
 

• File Menu (shows list of most recently accessed forms) 

 
 

• Site Map (provides a listing of Banner Menu groupings) 

 
 

Name of 
form here 

Related 
forms 
here 
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G. Navigating Banner Forms: 

 
• Blocks, Fields, Records and Tables:  A Banner form contains a logical layout of related 

information as shown below.   The layout contains records, fields and blocks.  A block contains 
sections of related information. A block may be enclosed in a beveled box with a colored border 
(usually gold or dark blue).  A Key Block is where you start on a form.  An Information Block contains 
the detail related to the Key Block.  Fields are labeled spaces within a block, usually where 
information is entered into.  A record is a group of fields that make up a logical unit (for example, a 
person record is made up of several fields: Last Name, First Name, Middle Name, Birth Date, Change 
indicator, Type) 

 
 
 

  
 

 
 
 

To navigate between blocks, use the Next Block or Previous Block toolbar icons: 
 

 
 
To navigate between records, use the Next Record or Previous Record toolbar icons: 
 

 

Separate 
blocks are 
shaded in 
blue, notice 
how they 
are 
outlined 
with a gold 
border 

Is an 
example of 
a field 

This shows 
Record 
number 
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• Tables:  A Table is a collection of data for a particular field. In this example below, table STVSUBJ 
shows a list of potential course codes: 

 

 
 
 

To see the values in a table, click on the arrow beside a field. If there is a table associated with that field, it 
will appear: 
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• Closing Banner Windows - Which “x” do I use? 
 

 
 

 
 

 

 
 
 
 
 

• Taskbar icons - How do I return to the last Banner window I was using? 

Banner sessions will typically open several tabs in your internet browser name “Oracle Fusion 
Middleware Service” that may appear like this: 
 

 
 
Please disregard these tabs. To return to the last active Banner window that was being used, look at the bottom 
on your computer screen in the taskbar, and click on the java icon, as shown below: 

 
This java icon will display the last active Banner window. 
 
 
 

  

Use this “X” to Exit out of a Banner 
window. If from the home screen it will 
close your Banner session. 

Use this “X” to close out of the current 
Banner form/window and return to the 
Main Menu. Can also be used to minimize 
a window. 
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• Job Submission-Parts of a Report form:  Reports in Banner can be accessed on-demand 
via Banner forms.  The report form is similar to an inquiry or modify form in that it contains blocks, 
fields and tables. Additionally, report forms contain parameter sets, and blocks called Printer 
Control, Parameter Values, and Submission. 

 

 
 

• Parameter Set:  When parameters are used in a report, they can be saved in a named 
set. For example, if a report is run weekly using the same parameters, the parameters can 
be entered once, and  by checking “Save Parameter set as” and naming it in the Submission 

block, the named set will be available by clicking on the   in the Parameter Set field. 
 

• Printer Control:  The Printer Control block is where a printer can be selected for output 

by clicking on the .  Or, if the report is to be saved to a file, the word “database” can be 
typed in the Printer field instead.  The word “DATABASE” must be entered in all caps or all 
lowercase. Do not mix cases (e.g. “Database” will not work) 

 
 

• Parameter Values:  Parameters are specific selection criteria for your report. Each 
parameter has a number and a description.  The parameter values are a powerful part of the 
report.  See more detail on this section, below: 



 
 15 

 

 
 
 

 

 

• Submission:  The Submission area is where you can save/name a parameter set.  To submit a report, 

click on “Submit” and then on the “Save” icon  in the Toolbar. 

 
 
• Review Output: If ‘database’ was selected for your report, the data for your report was saved in 

your Banner home directory.  To access this saved data, click on Options-Review Output after submitting 
and saving your report.   

 
 
Next, press F9 to LIST your output, OR click on the drop-down arrow to the right of the File Name box to 
display your output.  Note, the report may not immediately appear due to the time lag it takes to 
process. Please press F9 after 30 seconds to 1 minute. 
 

 

This section provides help text for the 
parameter and will indicate if the 

parameter is required 

The drop down arrow provides a table of 
values associated with the parameter to 

choose from. 
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Multiple files may be displayed.  The file that will be needed is a .lis file. The most recently generated file 
will be at the bottom of the list shown and will most likely be the output that you are looking for.  
Double click on the file and then select File > Save and the file will be saved in your internet browser.   
 
From your internet browser, you can then click File>Save As to save the file as a .txt file. Be sure to note 
where you are saving the file, and to select .txt as the File Type. 
 
Next, open your Excel program first.  Then, click File > Open, and browse to where you saved the .txt 
file. Be sure to search for “ALL” file types. 

 
 
You will be prompted by Excel to ‘delimit’ your data.  Most Banner reports will need to be delimited by 
“TAB”.  If you are opening data from a custom report like SZRDISK, you may also need to select 
‘COMMA’ as an additional delimiter.   
 
Complete the Excel Import Wizard and format the report as desired using Excel.  When the report is 
formatted, be sure to click File > Save As and save the report as File Type= Excel Workbook. 
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• Extract Data Key/No Key:  Some (not all) Banner forms are able to be extracted to 
Excel.  Typically, Banner forms that have multiple block areas cannot be extracted to Excel because of 
their complexity.  To find out if you can extract data from a form, hit “Help” while you are in the form 
and look to see if either “Extract Data with Key” or “Extract Data No Key” are enabled.  You then pick the 
one that is enabled and you will be able to extract your data to Excel. Usually, “Extract Data No Key” is 
enabled, meaning that the data will be extracted without the Key block (top block area in a form).  The 
data on the form will be extracted to columns. To include the column headings, you will need to edit 
your preferences first as shown below: 
 
To include  column headings in your extract: 
From Banner Main Menu:  Select “File”, “Preferences”, or type in GUAUPRF in the direct access box 
 

 
OR: 

 
  

GUAUPRF 
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In the  “Data Extract” block at bottom, click on the checkbox “Include Header Row in Data Extract” and hit 
F10 to Save. 
 

 
 
 
After the save, the hint line at the bottom of the screen will indicate your preference has been saved: 
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Now that your preferences have been saved, when you are on the Banner form that you wish to export, click on 
Help > Extract Data with Key or Extract Data No Key (sometimes no key is the only option available) 
 

 
 
Click OK to open the file with Excel: 

 
 
After the file is opened in Excel, it can be manipulated as desired. Be sure to save your file with File>Save As so that 
you can specify the file TYPE as ‘excel workbook’ instead of a .csv file. 
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H. Performing Searches and Queries 

• Searching:  When searching in Banner, use the following wildcards: 
% (percent sign) represents any number of characters 
_ (underscore) represents one occurrence of a character 
 
For example: 

 
%st% will return all entries that contain st (fast, student, street) 
st% will return entries that begin with st (student) 
%st will return entries that end in st (fast) 
_s will return entries that have s as a second character (ask) 
 
 
 
 
 

• Queries:  In Banner, a query can be used on a field to search for information. An example is to 
search for an ID based on a last name.  In this example, using the SPAIDEN form, click on the arrow 
in the ID box to ‘search’   

 
 

Next, choose ‘Person Search’ 
 

 
 
Next, enter the last name and then on the ‘Execute Query’ icon (or F8): 
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The ID and name of the person is shown as a result of the query: 
 

 
 
• Fetch Next Set:  if the search/query returned a list of matching records that did not fit on a single page, 

then Fetch Next Set will advance to the next page so that the records can be viewed. 
 
• Count Hits: Count Hits will return the number of records that match the criteria that’s been entered. In 

some cases, if the number of hits is too high, you may choose to enter additional criteria (in this 
example, a first initial in addition to last name). This will narrow down the returned results, or ‘hits’. 

 
 
 

Getting Help while using Banner: 
 

•  Online help:  Online help provides help by form name, topic, or searchable keywords 
 
Main Menu-Help Center 

 
 
Menu Bar>Help>Online Help 

 

 
Tool Bar icon 
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All three methods, above, display the Banner Help Center.  The Help Center Main Screen shows the Banner 
modules, as follows: 
 

 
 

 
• Dynamic Help:  Dynamic help provides on-the-spot specific help for the particular field or form that is 

currently being accessed. 
 

• On a field: Menu Bar click Help>Show keys, or via Keyboard hot key: Ctrl+F1,will display a list of 
appropriate entries for the current field 

 

After selecting a module to 
view, the help menu will display 
three tabs, Contents, Index and 
Search. 
 
When viewing the detail, a 
handy tool to use in an internet 
browser is CTRL-F, which will 
search or ‘find’ whatever 
information is needed. 
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On a field:   Auto Hint/Status Line – Hover or select field, see message line at bottom of screen

 

On a form:  Menu Bar click Help>Online help to display help about the form as listed in Help Center 
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•  Banner Bookshelf:  The Banner Bookshelf is a searchable PDF document that provides form-
based help.  Banner Bookshelp works in Internet Explorer and can be finicky when other browsers 
(Firefox or Chrome) are used. 
 
To access the Banner Bookshelf, go to the my.Fairfield.edu, portal, login and click on the “B” icon for 
Banner. Next, click on “Banner Bookshelf” in the right column 

 

 
 
 

• Site Map:  The Banner Site map offers help for topic by module.  The site map can be accessed via 
the Banner home page by clicking on Site Map near the Help Center in the right column. 
 

 
 

• my.Fairfield.edu  portal:  ITS4U Helpdesk>ITS Training>Banner Resources 

• Banner Commons:  http://www.eduworld.org/Commons (requires account 
sign up) 

http://www.eduworld.org/Commons
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Tips & Tricks 
• Did you know that you can click on the File menu and the most recently used 

Banner forms will appear at the bottom of the menu list? 

 
 
 

• Did you know that you can use your up/down arrow keys to scroll through 
recently used Banner forms? 
Press Up arrow, and last form that was used appears: 
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• Did you know that you can customize your “My Banner” menu to display 
commonly used forms? 
-Open Banner form GUAPMNU, or click on “My Banner” from the Banner 
home page hierarchical folders. 
-select the desired Banner form on the left and thenclick the arrow key to 
INSERT it to your personal menu on the right OR, enter the name of the form 
in the column on the right side if you know the form name. 
 

 
 
-click SAVE icon 
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• Did you know that you can add links in “My Links”? 
-Access the Banner form GUAUPRF, OR simply click on a “Personal Link” on the 
home screen: 

   
-Click on the My Links tab and enter your desired URL’s. Notice that the setup 
for these links comes in pairs: 

 

1 

2 
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• Did you know that you can Edit Banner Preferences to change screen color? 

-Access the Banner form GUAUPRF 
-Click on the Display Preferences tab and choose the desired color code. You 
can easily find color codes by searching in your internet browser.  Simply 
search using “RGB color codes”. 

 
• Did you know that you can create Quickflows to automatically bring you 

through a set of related forms? 
-Access the Banner form GUAQUIK 
-Name your QuickFlow 
-Select the names of the Banner forms in sequential order for your process, 
and add them to the “current forms” using the arrows in the center column as 
shown below: 

 
-Save your QuickFlow 
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Appendix A:  Naming Conventions 
 

The seven-character form name  

Every form has an abbreviated seven-character form name.  Most of the time, forms are referred to by 
this seven-character form name. 

Position 1 

Identifies the Banner product owning the form, report, process or table. 

Products are Accounts Receivable, Advancement, Finance, Financial Aid, General, Human Resources, 
Student and Technical.  

The following table contains the codes for various Banner products. 

 

Code Product/Purpose 

A Advancement 

F Finance 

G General 

N Position Control 

P Payroll 

R Financial Aid 

S Student 

T Accounts Receivable 
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Position 2 

Identifies the application module owning the form, report, process or table.   

Unique to the product identified in position 1. 

For each Banner product, the second position would be one of the following codes. 

 

Code Product/Purpose 

Position 2 for Banner Advancement 

A Membership 

D Designation 

E Event Management 

F Campaign 

G Pledge and Gift/Pledge Payment 

L Label 

M Prospect Management 

O Organization 

P Constituent/Person 

S Solicitor Organization 

T Validation form/table 

U Utility 

V Reserved-Canadian Solution Center 

X Expected Matching Gift 

Z Indicates a custom form or report built by Fairfield University 
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Code Product/Purpose 

Position 2 for Banner Financial Aid 

B Budgeting 

C Record Creation 

E Electronic Data Exchange 

F Funds Management 

H History and Transcripts 

J Student Employment 

L Logging 

N Need Analysis 

O Common Functions 

P Packaging and Disbursements 

R Requirements Tracking 

S Student System Shared Data 

T Validation form/table 

U Utility 

V Reserved-Canadian Solution Center 
 
 

  



 
 32 

Code Product/Purpose 

Position 2 for Banner HR/Payroll (P) Position Control (N) 

A Application 

B Budget 

C COBRA 

D Benefit/Deductions 

E Employee 

H Time Reporting/History 

O Overall 

P General Person 

R Electronic Approvals 

S Security 

T Validation/rule table 

U Utility 

V Reserved-Canadian Solution Center 

X Tax Administration 
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Code Product/Purpose 

Position 2 for Banner Finance 

A Accounts Payable 

B Budget Development 

C Cost Accounting 

E Electronic Data Interchange 

F Fixed Assets 

G General Ledger 

I Investment Management 

N Endowment Management 

O Operations 

P Purchasing/Procurement 

R Research Accounting 

S Stores Inventory 

T Validation form/table 

U Utility 

V Reserved-Canadian Solution Center 

X Archive/Purge 
 

 
  



 
 34 

Code Product/Purpose 

Position 2 for Banner General 

E Event Management 

J Job Submission 

L Letter Generation 

O Overall 

P Purge 

S Security 

T Validation form/table 

U Utility 

V Reserved-Canadian Solution Center 

X Cross Product 
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Code Product/Purpose 

Position 2 for Banner Student 

A Admissions 

C Catalog 

E Support Services 

F Registration/Fee Assessment 

G General Student 

H Grades/Academic History 

I Faculty Load 

K Reserved for SunGard Higher Education International 

L Location Management 

M CAPP 

O Overall 

P Person 

R Recruiting 

S Schedule 

T Validation form/table 

U Utility 
 
 

 
  



 
 36 

Code Product/Purpose 

Position 2 for Banner Accounts Receivable (R) 

F Finance Accounts Receivable 

G General Accounts Receivable 

O Overall 

R Research Accounting 

S Student Accounts Receivable 

T Validation form/table 

U Utility 

V Reserved-Canadian Solution Center 

Position 2 for Banner Information Access/Kiosk (I) 

R Financial Aid 

S Student 

Position 2 for Banner Document Management Suite (BDMS) (E) 

T Validation form/table 

X Banner Document Management Suite 

Position 2 for Banner All Products 

W Reserved for client forms or modules used within a Banner 
application 

Y (character in position 1 does not equal W, Y, or Z) 
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Position 3 

Identifies the type of form, report, process or table. 

Codes are the same for all Banner products.   
 

Code Type of Form/Process 

A Application  

B Base Table 

I Inquiry 

P Process 

R Rule Table, Repeating Table, Report or Process 

V Validation 

M Maintenance 

 
 

Positions 4, 5, 6, 7 

Identifies a unique four-character code for the form, report, process or table. 

The following are some examples of four-character names. 

Code Purpose 

***IDEN Identification 

***PINC Position Incumbent 

***STDN Student Relation 

***PERS Person 
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